System Requirements - Professional Learning Online

Document created by Community User on Aug 9, 2017
Version 1Show Document
  • View in full screen mode
Introduction
To achieve optimal performance in Professional Learning Online, please refer to the following system requirements and recommendations.

Information
Back to Help Center

 
Supported Web Browsers:

  • Internet Explorer 11
  • Firefox (v.44+)
  • Safari (v.6.0.2+)
  • Chrome (v.50+)
 
iOS Support

Professional Learning Online is supported on iOS devices via an app. To install and use the app:
  1. Download the free Mobile LMS app from the app store.
  2. When prompted, enter the LMS path: prolearning.nwea.org
  3. On the sign in page, select Sign in with SAML/ADFS.
  4. Enter your email address and password to sign in.

 
Additional Requirements:

  • Pop-up blockers must be disabled
  • Minimum screen resolution must be 1024 x 768 or higher.
  • JavaScript must be enabled
  • Flash Player 20 or newer (required for some video content) must be installed
  • Adobe Reader v. 2017.009+ or other PDF viewer must be installed (Chromebooks can use the free PDF Escape website).

 
Troubleshooting Failed Browser Components

When you log in to Professional Learning Online, the system will check whether your browser meets the minimum requirements. If any of the browser components failed during the system check, use the information below to find the solutions for your browser.

 
Browser Check

Please use a supported web browser from the list above.

 
Flash Installed

Some content within courses may require the installation of third party plug-ins such as Adobe Flash and Adobe Reader. In each case there should be a notification and link informing you that you need to install the new plug-in if it is not already installed. Be careful that you only install trusted plug-ins that are necessary for the course content. Malicious plug-ins can be dangerous to your computer. If you are not prompted to install Flash automatically, you can download it here: http://get.adobe.com/flashplayer/

 
Disable Pop-up blockers

Pop-up windows are used throughout the Professional Learning Online site. You may need to disable pop-up blocking for your browser. You may find solutions for enabling pop-ups in your browser here:

 
Resolution Check

Many videos in Professional Learning Online are optimized for a display resolution that is set to 1024 x 768 or higher. To adjust the screen resolution, see the instructions below for your operating system:  
Enable cooki
es from third parties
Third party cookies are allowed by default on all supported browsers. You may have a custom security setting that has disabled cookies. To enable cookies, see the instructions below for your browser:

 
Enable JavaScript in your browser

JavaScript should be enabled by default on all supported browsers. If you have disabled JavaScript, see the instructions below to re-enable it in your browser:

 
Adobe Reader Installed

Some content within courses may require the installation of third party plug-ins such as Adobe Flash and Adobe Reader. In each case there should be a notification and link informing you that you need to install a new plug-in. Be careful that you only install trusted plug-ins that are necessary for the course content. Malicious plug-ins can be dangerous to your computer. If you are not prompted to install Adobe Reader automatically, you can download it here: http://get.adobe.com/reader/

Article Number
000003421

Attachments

    Outcomes